废旧笔记本如何刷openwrt,并做为二级路由实现局域网科学上网

废旧笔记本如何刷openwrt,并做为二级路由实现局域网科学上网

Scroll Down

废旧笔记本如何刷openwrt,并做为二级路由实现局域网科学上网

官网介绍

OpenWrt项目是一个针对嵌入式设备的Linux操作系统。OpenWrt不是一个单一且不可更改的固件,而是提供了具有软件包管理功能的完全可写的文件系统。这使您可以不使用供应商提供的应用程序选择和配置,而是通过使用软件包来定制设备以适应任何应用程序。对于开发人员来说,OpenWrt是一个无需围绕它构建完整固件就能开发应用程序的框架; 对于普通用户来说,这意味着拥有了完全定制的能力,能以意想不到的方式使用该设备

准备

PE盘制作

老毛桃
U深度

下载openwrt固件及写盘工具

1.openwrt固件获取地址
官方下载地址
koolshare下载地址

2.写盘工具
DiskImage 或其他

将下载好的固件和写盘工具DiskImage拷贝至PE盘中,将U盘插入笔记本,开机并从U盘启动,进去电脑后运行DiskImage将固件写入即可(需选择物理磁盘(非分区盘))

Openwrt网络配置

成功安装后打开配置文件/etc/config/network 并编辑保存

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd68:088c:8c8f::/48'
	option multipath 'disable'
	option mptcp_path_manager 'fullmesh'
	option mptcp_scheduler 'default'
	option congestion 'bbrplus'
	option mptcp_checksum '0'
	option mptcp_debug '0'
	option mptcp_syn_retries '5'
	option mptcp_fullmesh_num_subflows '1'
	option mptcp_fullmesh_create_on_err '1'
	option mptcp_ndiffports_num_subflows '1'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr '192.168.1.2' //修改此处
	option netmask '255.255.255.0'
	option ip6assign '60'
	option multipath 'off'
	option gateway '192.168.1.1' //我的主路由器网关
	option dns '114.114.114.114'

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'
用网线连接路由器联网即可,web地址192.168.1.2,用户名root,密码koolshare

科学工具下载

酷软商店已经下架相关工具,可从这里下载

终端配置

将客户端网关配置路由器Ip即可